Современные технологии автоматизации» («СТА») —  журнал для квалифицированных специалистов по промышленной автоматизации Форум СТА — современные технологии автоматизации Домашняя страница
Домашняя страница форума CTA Домашняя страница форума CTA > II. АСУТП и SCADA > ПЛК и микроконтроллеры
  Активные темы Активные темы
  FAQ FAQ  Искать в форуме   Зарегистрироваться Зарегистрироваться  Вход в систему Вход в систему

Проблема с WAGO 750-815

 Ответить Ответить Страница  <12
Автор
Сообщение
Petrov Смотреть выпадающим
Действительный член
Действительный член
Аватар

Присоединился: 15 Январь 2004
Категория: Russian Federation
Online Status: Offline
Публикации: 805
Свойства публикации Свойства публикации   Ответить, цитируя автора - Petrov Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Тема сообщения: Проблема с WAGO 750-815
    Опубликовано: 31 Октябрь 2007 12:54

вроде бы нормально...

В скаде ASCII/RTU ?

Бывало, я поначалу накалывался на распайке с номерами контактов, т.е. распаивал зеркально. :) тоже проверьте на всякий случай. нумерация контактов со стороны пайки слева-направо.

больше ничем помочу не смогу.

 

Наверх
waldius Смотреть выпадающим
Новичок
Новичок


Присоединился: 10 Октябрь 2007
Категория: Russian Federation
Online Status: Offline
Публикации: 33
Свойства публикации Свойства публикации   Ответить, цитируя автора - waldius Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 15 Ноябрь 2007 10:20
Первоначально опубликовано Petrov

вроде бы нормально...

В скаде ASCII/RTU ?

Бывало, я поначалу накалывался на распайке с номерами контактов, т.е. распаивал зеркально. :) тоже проверьте на всякий случай. нумерация контактов со стороны пайки слева-направо.

больше ничем помочу не смогу.

 

Оказалось что проблема была с портом промышленного компьютера, что-то там китайцы намудрили...

Купили преобразователь USB-RS485 - все сразу полетело, адресация меня конечно удивила, я первый раз с модбас сталкиваюсь... не так я документацию понял... :) но вроде со всем разобрался... Спасибо за участие! :)

Наверх
Mustafa Смотреть выпадающим
Новичок
Новичок
Аватар

Присоединился: 13 Май 2008
Категория: Russian Federation
Online Status: Offline
Публикации: 39
Свойства публикации Свойства публикации   Ответить, цитируя автора - Mustafa Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 12 Сентябрь 2018 16:22
Кто может подсказать адреса с которых читать? Например какому адресу соответствует область памяти %MW1 ? В мануале не нашел..
Наверх
Антон Соколов Смотреть выпадающим
Участник
Участник
Аватар

Присоединился: 29 Май 2014
Online Status: Offline
Публикации: 85
Свойства публикации Свойства публикации   Ответить, цитируя автора - Антон Соколов Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 12 Сентябрь 2018 16:38
Вроде должно работать следующее соответствие:

%MW0 - %MW12287
0×3000 - 0×5FFF

Антон Соколов
Наверх
Mustafa Смотреть выпадающим
Новичок
Новичок
Аватар

Присоединился: 13 Май 2008
Категория: Russian Federation
Online Status: Offline
Публикации: 39
Свойства публикации Свойства публикации   Ответить, цитируя автора - Mustafa Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 12 Сентябрь 2018 16:58
Спасибо, видимо причина не в адресах. Выдает ошибку "Received Invalid Response to Modbus Query"
Наверх
Антон Соколов Смотреть выпадающим
Участник
Участник
Аватар

Присоединился: 29 Май 2014
Online Status: Offline
Публикации: 85
Свойства публикации Свойства публикации   Ответить, цитируя автора - Антон Соколов Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 12 Сентябрь 2018 17:01
Думаю, в данном случае имеет место физическая проблема с подключением
Антон Соколов
Наверх
Mustafa Смотреть выпадающим
Новичок
Новичок
Аватар

Присоединился: 13 Май 2008
Категория: Russian Federation
Online Status: Offline
Публикации: 39
Свойства публикации Свойства публикации   Ответить, цитируя автора - Mustafa Ответить, цитируя автора -  ОтветитьОтвет Прямая ссылка на эту публикацию Опубликовано: 14 Сентябрь 2018 09:10
В общем фиг его знает что было... Действия были следующие:
1. опросили с помощью moxa u-port 1130 контроллер 750-815/300-00 - результат Illegal response
2. опросили с помощью модуля 750-652 контроллер 750-815/300-00 - результат Read Ok
3. опросили с помощью moxa u-port 1130 модуль 750-652  - результат Read Ok
4. опросили с помощью moxa u-port 1130 контроллер 750-815/300-00 - результат Read Ok

Спасибо специалистам из Wago, всю работу делали у них в офисе.
возможно в процессе работы изменили какие-то уставки и сами не заметили... с физикой ничего не делали.
Но выяснился один момент, что читать можно только с адресов привязанных к модулям, т.е. с области памяти М не удалось ничего прочитать (возможно мы просто до этого не докопали).
Наверх
 Ответить Ответить Страница  <12

Переход на форум Права доступа на форуме Смотреть выпадающим

Bulletin Board Software by Web Wiz Forums® version 9.64
Powered by Web Wiz Forums Free Express Edition
Copyright ©2001-2009 Web Wiz